import re
regex = re.compile(r"/api/documentDownload/(.*)$")
test_str = ("/inga-rest/wallet/aaa\n\n"
"/inga-rest/wallet/MA503122/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA471075/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA471420/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/YYI9878/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA510926/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA299306/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA515464/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA473773/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA515578/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA215692/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA468301/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MV974901/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA486190/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA525372/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA470176/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA281510/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA464449/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA472241/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA482703/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA468533/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA459862/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA501495/products?workflow=CERTIFIED_IDENTITY\n"
"/inga-rest/wallet/MA162619/products?workflow=CERTIFIED_IDENTITY")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")