import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z0-9\\x{00C0}-\\x{017F}\\s-\\/]+)\\s+Statement(?:\\s*:)?((?:.| )*)\\s+Source\\s*:?((?:.| )*)\\s+Reasoning\\s*:?((?:.| )*)";
final String string = "ASG-SF-01-ICF-01-FR010\n"
+ "Statement:\n"
+ "Source:Functional description of first line of protection P/S related I&C functions to reach NHSS.\n"
+ "Reasoning:This time is related to the SG level (WR) measurement.This response time compliance enables to ensure the function efficiency in the safetyanalyses.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}