import re
regex = re.compile(r"^([A-Za-z0-9\x{00C0}-\x{017F}\s-\/]+)\s+Statement(?:\s*:)?((?:.| )*)\s+Source\s*:?((?:.| )*)\s+Reasoning\s*:?((?:.| )*)")
test_str = ("ASG-SF-01-ICF-01-FR010\n"
"Statement:\n"
"Source:Functional description of first line of protection P/S related I&C functions to reach NHSS.\n"
"Reasoning:This time is related to the SG level (WR) measurement.This response time compliance enables to ensure the function efficiency in the safetyanalyses.\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")