re = /^([A-Za-z0-9\x{00C0}-\x{017F}\s-\/]+)\s+Statement(?:\s*:)?((?:.| )*)\s+Source\s*:?((?:.| )*)\s+Reasoning\s*:?((?:.| )*)/
str = 'ASG-SF-01-ICF-01-FR010
Statement:
Source:Functional description of first line of protection P/S related I&C functions to reach NHSS.
Reasoning:This time is related to the SG level (WR) measurement.This response time compliance enables to ensure the function efficiency in the safetyanalyses.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end