re = /^(\/\w+\h"[^"]+"\h*)/
str = '/ErrorStdOut "C:\\Users\\guinness\\Desktop\\Test.au3" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end