import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[Ii][Bb][Aa][Nn]\\s).*[Nn][Ll]\\s?\\d{2}\\s?[a-zA-Z]{4}[0 ]\\s?\\d{9,10}";
final String string = "Uw BTW nummer NL80\n"
+ " IBAN NL 11abna0317164300asdfasf234\n"
+ "iBAN NL21ABNA0417134300 22\n"
+ "Iban: NL 29 ABNA 401422366f sdf\n"
+ "IBAN :NL 39 ABNA 0822416395s\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}