import re
regex = re.compile(r"(?<=[Ii][Bb][Aa][Nn]\s).*[Nn][Ll]\s?\d{2}\s?[a-zA-Z]{4}[0 ]\s?\d{9,10}", flags=re.MULTILINE)
test_str = ("Uw BTW nummer NL80\n"
" IBAN NL 11abna0317164300asdfasf234\n"
"iBAN NL21ABNA0417134300 22\n"
"Iban: NL 29 ABNA 401422366f sdf\n"
"IBAN :NL 39 ABNA 0822416395s\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")