re = /(?<=[Ii][Bb][Aa][Nn]\s).*[Nn][Ll]\s?\d{2}\s?[a-zA-Z]{4}[0 ]\s?\d{9,10}/m
str = 'Uw BTW nummer NL80
IBAN NL 11abna0317164300asdfasf234
iBAN NL21ABNA0417134300 22
Iban: NL 29 ABNA 401422366f sdf
IBAN :NL 39 ABNA 0822416395s
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end