using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=\{([^{}]+)\}(?![^@]*[^=@]{)";
string input = @"singleline:
Year: ={year}</p><p>Director: ={director}<ul>@{ins}<p>inside1: ={in1}</p><p>in2: ={in2}</p>{ins}</ul>
Multiline:
Year: ={year}</p><p>Director: ={director}
<ul>@{actors}<li class=""#{class}"">={actor}</li><li class=""#{class}"">={actor}</li>{actors}</ul>\";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}