using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(\d+).*";
string input = @"CTRL_RADIOCOLUMNS_1
CTRL_RADIOCOLUMNS_22
CTRL_RADIOCOLUMNS_333
CTRL_RADIOCOLUMNS_4444";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}