// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*(\d+).*").unwrap();
let string = "CTRL_RADIOCOLUMNS_1
CTRL_RADIOCOLUMNS_22
CTRL_RADIOCOLUMNS_333
CTRL_RADIOCOLUMNS_4444";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}