using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#\d+=.+\(')(.+)('(.|\s)+, Default:)((\d))('.+\s)";
string substitution = @"$1$5$3$4$5$6$7";
string input = @"#202=IFCBUILDINGELEMENTPROXY('0RIN1Zann9dfafNQrMyG47',#18,
'Insitu Reinforced Concrete--Columns','0, C136-SWN-S-DMA-M123_A-30100.dgn
, Default:61883','Insitu Reinforced Concrete:Columns',#11085,#10245,$,$);
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}