// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(#\d+=.+\(')(.+)('(.|\s)+, Default:)((\d))('.+\s)").unwrap();
let string = "#202=IFCBUILDINGELEMENTPROXY('0RIN1Zann9dfafNQrMyG47',#18,
'Insitu Reinforced Concrete--Columns','0, C136-SWN-S-DMA-M123_A-30100.dgn
, Default:61883','Insitu Reinforced Concrete:Columns',#11085,#10245,$,$);
";
let substitution = "$1$5$3$4$5$6$7";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}