$re = '~(#\d+=.+\(\')(.+)(\'(.|\s)+, Default:)((\d))(\'.+\s)~m';
$str = '#202=IFCBUILDINGELEMENTPROXY(\'0RIN1Zann9dfafNQrMyG47\',#18,
\'Insitu Reinforced Concrete--Columns\',\'0, C136-SWN-S-DMA-M123_A-30100.dgn
, Default:61883\',\'Insitu Reinforced Concrete:Columns\',#11085,#10245,$,$);
';
$subst = "$1$5$3$4$5$6$7";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;