$re = '/^channel = "(.+)"$/m';
$str = '# If you wish to update this file, please read
# <https://thebevyflock.github.io/bevy_cli/contribute/linter/how-to/upgrade-rust-toolchain.html>.
[toolchain]
# Writing custom lints requires using nightly Rust. We pin to a specific version of nightly version
# so that builds are reproducible. Note that we use the Regex `^channel = "(.+)"$` to match this
# line, so be wary when changing its formatting.
channel = "nightly-2025-06-26"
# These components are required to use `rustc` crates. Note that if you change these, you may need
# to also update `bevy_lint/action.yml`.
components = ["rustc-dev", "llvm-tools-preview"]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);