// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^channel = "(.+)"$"#).unwrap();
let string = "# If you wish to update this file, please read
# <https://thebevyflock.github.io/bevy_cli/contribute/linter/how-to/upgrade-rust-toolchain.html>.
[toolchain]
# Writing custom lints requires using nightly Rust. We pin to a specific version of nightly version
# so that builds are reproducible. Note that we use the Regex `^channel = \"(.+)\"$` to match this
# line, so be wary when changing its formatting.
channel = \"nightly-2025-06-26\"
# These components are required to use `rustc` crates. Note that if you change these, you may need
# to also update `bevy_lint/action.yml`.
components = [\"rustc-dev\", \"llvm-tools-preview\"]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}