# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^channel = \"(.+)\"$"
test_str = ("# If you wish to update this file, please read\n"
"# <https://thebevyflock.github.io/bevy_cli/contribute/linter/how-to/upgrade-rust-toolchain.html>.\n\n"
"[toolchain]\n"
"# Writing custom lints requires using nightly Rust. We pin to a specific version of nightly version\n"
"# so that builds are reproducible. Note that we use the Regex `^channel = \"(.+)\"$` to match this\n"
"# line, so be wary when changing its formatting.\n"
"channel = \"nightly-2025-06-26\"\n\n"
"# These components are required to use `rustc` crates. Note that if you change these, you may need\n"
"# to also update `bevy_lint/action.yml`.\n"
"components = [\"rustc-dev\", \"llvm-tools-preview\"]\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.