import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\#(\n"
+ "[0-9a-fA-F]{6}|\n"
+ "[0-9a-fA-F]{3}\n"
+ ")$";
final String string = "#000\n"
+ "#123\n"
+ "#90a\n"
+ "#abc\n"
+ "#def\n"
+ "#fff\n"
+ "#000000\n"
+ "#890ABC\n"
+ "#ABCDEF\n"
+ "#ffffff\n\n"
+ "#1\n"
+ "#12\n"
+ "#1234\n"
+ "#12345\n"
+ "#1234567\n"
+ "#ggg\n"
+ "#XYZ\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}