const regex = /^\#(
[0-9a-fA-F]{6}|
[0-9a-fA-F]{3}
)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\#(
[0-9a-fA-F]{6}|
[0-9a-fA-F]{3}
)$', 'gm')
const str = `#000
#123
#90a
#abc
#def
#fff
#000000
#890ABC
#ABCDEF
#ffffff
#1
#12
#1234
#12345
#1234567
#ggg
#XYZ
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}