import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\n"
+ " ( # regular executable builds\n"
+ " (?!lib)([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(release|debug)\n"
+ " )\n"
+ " |\n"
+ " ( # library builds\n"
+ " lib([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(shared|static|mixed)_(release|debug)\n"
+ " )\n"
+ " |\n"
+ " ( # syncing source code of a project from git or something else\n"
+ " ([^_]+)_src\n"
+ " )\n"
+ " |\n"
+ " ( # static code analizer\n"
+ " ([^_]+)_analyze_(cppcheck|scan-build)\n"
+ " )\n"
+ " |\n"
+ " ( # package builds\n"
+ " ([^_]+)_pkg_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(stable|testing|nightly|unstable)\n"
+ " )\n"
+ ")$";
final String string = "libtoxcore_build_windows_x86_shared_release";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}