re = /^(
( # regular executable builds
(?!lib)([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(release|debug)
)
|
( # library builds
lib([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(shared|static|mixed)_(release|debug)
)
|
( # syncing source code of a project from git or something else
([^_]+)_src
)
|
( # static code analizer
([^_]+)_analyze_(cppcheck|scan-build)
)
|
( # package builds
([^_]+)_pkg_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(stable|testing|nightly|unstable)
)
)$/x
str = 'libtoxcore_build_windows_x86_shared_release'
# Print the match result
str.match(re) do |match|
puts match.to_s
end