import Foundation
let pattern = ##"""
^(
( # regular executable builds
(?!lib)([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(release|debug)
)
|
( # library builds
lib([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(shared|static|mixed)_(release|debug)
)
|
( # syncing source code of a project from git or something else
([^_]+)_src
)
|
( # static code analizer
([^_]+)_analyze_(cppcheck|scan-build)
)
|
( # package builds
([^_]+)_pkg_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(stable|testing|nightly|unstable)
)
)$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"libtoxcore_build_windows_x86_shared_release"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}