using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(
( # regular executable builds
(?!lib)([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(release|debug)
)
|
( # library builds
lib([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(shared|static|mixed)_(release|debug)
)
|
( # syncing source code of a project from git or something else
([^_]+)_src
)
|
( # static code analizer
([^_]+)_analyze_(cppcheck|scan-build)
)
|
( # package builds
([^_]+)_pkg_(windows|debian|ubuntu|centos|fedora|osx|android|illumos)_(x86_64|x86|arm|arm64)_(stable|nightly)_(release|debug)
)
)$";
string input = @"libtoxcore_build_windows_x86_shared_release";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}