// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)^(
( # regular executable builds
(?!lib)([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(release|debug)
)
|
( # library builds
lib([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(shared|static|mixed)_(release|debug)
)
|
( # syncing source code of a project from git or something else
([^_]+)_src
)
|
( # static code analizer
([^_]+)_analyze_(cppcheck|scan-build)
)
|
( # package builds
([^_]+)_pkg_(windows|debian|ubuntu|centos|fedora|osx|android|illumos)_(x86_64|x86|arm|arm64)_(stable|nightly)_(release|debug)
)
)$").unwrap();
let string = "libtoxcore_build_windows_x86_shared_release";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}