$re = '/^(
( # regular executable builds
(?!lib)([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(release|debug)
)
|
( # library builds
lib([^_]+)_build_(windows|linux|osx|android|illumos)_(x86_64|x86|arm|arm64)_(shared|static|mixed)_(release|debug)
)
|
( # syncing source code of a project from git or something else
([^_]+)_src
)
|
( # static code analizer
([^_]+)_analyze_(cppcheck|scan-build)
)
|
( # package builds
([^_]+)_pkg_(windows|debian|ubuntu|centos|fedora|osx|android|illumos)_(x86_64|x86|arm|arm64)_(stable|nightly)_(release|debug)
)
)$/x';
$str = 'libtoxcore_build_windows_x86_shared_release';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);