$re = '/.(?!i18n-.*\.js)(?:css|js)$/m';
$str = 'i18n-.js
test.js
i18n.js
i18n2.js
m43.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);