import re
regex = re.compile(r".(?!i18n-.*\.js)(?:css|js)$", flags=re.MULTILINE)
test_str = ("i18n-.js\n"
"test.js\n"
"i18n.js\n"
"i18n2.js\n"
"m43.js")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")