re = /.(?!i18n-.*\.js)(?:css|js)$/m
str = 'i18n-.js
test.js
i18n.js
i18n2.js
m43.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end