const regex = /(^([\w\.\-]+)@([\w\-])+((\.(?!EMAIL)(?!email)(?!com\.com)([a-zA-z]){2,9}){1,6})$)|(^$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^([\\w\\.\\-]+)@([\\w\\-])+((\\.(?!EMAIL)(?!email)(?!com\\.com)([a-zA-z]){2,9}){1,6})$)|(^$)', 'gm')
const str = `
renanpcosta@gmai.com
renanpcosta@hotmail.com.br
lucas@smf.curitiba.pr.gov.br
lucas@sga.pucminas.br
lucas@ga.unicamp.br
lucas@smf.curitiba.pr.gov.br
lucas@.com.com.com
lucas@com.com.com.com.com.com
lucas@com.com.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}