# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^([\w\.\-]+)@([\w\-])+((\.(?!EMAIL)(?!email)(?!com\.com)([a-zA-z]){2,9}){1,6})$)|(^$)"
test_str = ("\n"
"renanpcosta@gmai.com\n"
"renanpcosta@hotmail.com.br\n\n"
"lucas@smf.curitiba.pr.gov.br\n"
"lucas@sga.pucminas.br\n"
"lucas@ga.unicamp.br\n"
"lucas@smf.curitiba.pr.gov.br\n\n"
"lucas@.com.com.com\n"
"lucas@com.com.com.com.com.com\n"
"lucas@com.com.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.