use strict;
my $str = '#Valid
{DateTime}
{datetime, "dd mmm yyyy"}
{datetime, " kk kkk kkk cskmokk sdjjdo0987 "}
{dAtetime, "dd mmm yyyy", "dddc"} <-- problem! Only matching one set
{datetime, "hh.mm tt dd/MM/yyyy"}
#Partially Valid
{}{{dAtetime, "dd mmm yyyy", "dddc"}dsdc}{{s}
{datetime}{custom event start datetime}
{datetime{datetime}}
#Invalid
{ihbsaicb { dAtetime, "dd mmm yyyy", "dddc"}
{datetime, }
{datetime,""}
{date,""}
{dAtetime, "dd mmm yyyy,}';
my $regex = qr/(?<fullString>\{(?<tag>datetime)(?:\,\s*\"+(?<param>.+?)\"\s*)*\})/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}