// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(?<fullString>\{(?<tag>datetime)(?:\,\s*\"+(?<param>.+?)\"\s*)*\})"#).unwrap();
let string = "#Valid
{DateTime}
{datetime, \"dd mmm yyyy\"}
{datetime, \" kk kkk kkk cskmokk sdjjdo0987 \"}
{dAtetime, \"dd mmm yyyy\", \"dddc\"} <-- problem! Only matching one set
{datetime, \"hh.mm tt dd/MM/yyyy\"}
#Partially Valid
{}{{dAtetime, \"dd mmm yyyy\", \"dddc\"}dsdc}{{s}
{datetime}{custom event start datetime}
{datetime{datetime}}
#Invalid
{ihbsaicb { dAtetime, \"dd mmm yyyy\", \"dddc\"}
{datetime, }
{datetime,\"\"}
{date,\"\"}
{dAtetime, \"dd mmm yyyy,}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}