$re = '/(?<fullString>\{(?<tag>datetime)(?:\,\s*\"+(?<param>.+?)\"\s*)*\})/mi';
$str = '#Valid
{DateTime}
{datetime, "dd mmm yyyy"}
{datetime, " kk kkk kkk cskmokk sdjjdo0987 "}
{dAtetime, "dd mmm yyyy", "dddc"} <-- problem! Only matching one set
{datetime, "hh.mm tt dd/MM/yyyy"}
#Partially Valid
{}{{dAtetime, "dd mmm yyyy", "dddc"}dsdc}{{s}
{datetime}{custom event start datetime}
{datetime{datetime}}
#Invalid
{ihbsaicb { dAtetime, "dd mmm yyyy", "dddc"}
{datetime, }
{datetime,""}
{date,""}
{dAtetime, "dd mmm yyyy,}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);