using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/i>\s*(.*)\n.*<span class=""text-muted""";
string input = @"<div class=""col-md-4 col-sm-6 col-lg-3"">
<small class=""text-muted pull-right"">4.4</small>
<i class=""custom-icon""></i>
desired content to retrieve
<span class=""text-muted"">some other text here</span>
</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}