import re
regex = re.compile(r"<\/i>\s*(.*)\n.*<span class=\"text-muted\"", flags=re.MULTILINE | re.DOTALL)
test_str = ("<div class=\"col-md-4 col-sm-6 col-lg-3\">\n"
" <small class=\"text-muted pull-right\">4.4</small>\n"
" <i class=\"custom-icon\"></i>\n"
" desired content to retrieve\n"
" <span class=\"text-muted\">some other text here</span>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")