import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/i>\\s*(.*)\\n.*<span class=\"text-muted\"";
final String string = "<div class=\"col-md-4 col-sm-6 col-lg-3\">\n"
+ " <small class=\"text-muted pull-right\">4.4</small>\n"
+ " <i class=\"custom-icon\"></i>\n"
+ " desired content to retrieve\n"
+ " <span class=\"text-muted\">some other text here</span>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}