#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)sent\sfrom\s(my|a)? (samsung\sgalaxy|sony\sxperia™)? (smartphone|mobile|iphone|windows) (phone|device)?"
Local $sString = " sent "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")