re = /sent\sfrom\s(my|a)? (samsung\sgalaxy|sony\sxperia™)? (smartphone|mobile|iphone|windows) (phone|device)?/i
str = ' sent '
# Print the match result
str.match(re) do |match|
puts match.to_s
end