const regex = new RegExp('sent\\sfrom\\s(my|a)? (samsung\\sgalaxy|sony\\sxperia™)? (smartphone|mobile|iphone|windows) (phone|device)?', 'i')
const str = ` sent `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}