import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<category>\\D+)\\s+(?P<value>[\\d.]+)\\s+(?P<unit>.+)";
final String string = "Weight 229.6104534866 g\n"
+ "Energy 374.79170898476 kcal\n"
+ "Total lipid (fat) 22.163422468932 g\n"
+ "Carbohydrate, by difference 13.641848209743 g\n"
+ "Sugars, total 4.3691034101428 g\n"
+ "Protein 29.256342349938 g\n"
+ "Sodium, Na 468.99386390008 mg ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}