#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((|\s|\n)*subnet(|\s|\n)*((\d{1,3}.){3}(\d{1,3}))(|\s|\n)*netmask(|\s|\n)*((\d{1,3}.){3}(\d{1,3}))(|\s|\n)*\{(|\s|\n)+((|\s|\n)+host(|\s|\n)*(\w+)(|\s|\n)*\{(|\s|\n)*(\w*)\:(\w*)\;(|\s|\n)*\}(|\s|\n)*)*\})"
Local $sString = "#DHCP Server Configuration file." & @CRLF & _
"" & @CRLF & _
"deny unknown-clients;" & @CRLF & _
"" & @CRLF & _
"subnet 10.8.140.2 netmask 255.255.255.255 {" & @CRLF & _
" host example{" & @CRLF & _
" optian:param; " & @CRLF & _
" }" & @CRLF & _
" host example2{" & @CRLF & _
" option2:param2;" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"subnet 20.8.110.1 netmask 255.255.255.255 {" & @CRLF & _
" host example{" & @CRLF & _
" optian:param; " & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"subnet 20.8.110.1 netmask 255.255.255.255 {" & @CRLF & _
"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")