import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((|\\s|\\n)*subnet(|\\s|\\n)*((\\d{1,3}.){3}(\\d{1,3}))(|\\s|\\n)*netmask(|\\s|\\n)*((\\d{1,3}.){3}(\\d{1,3}))(|\\s|\\n)*\\{(|\\s|\\n)+((|\\s|\\n)+host(|\\s|\\n)*(\\w+)(|\\s|\\n)*\\{(|\\s|\\n)*(\\w*)\\:(\\w*)\\;(|\\s|\\n)*\\}(|\\s|\\n)*)*\\})";
final String string = "#DHCP Server Configuration file.\n\n"
+ "deny unknown-clients;\n\n"
+ "subnet 10.8.140.2 netmask 255.255.255.255 {\n"
+ " host example{\n"
+ " optian:param; \n"
+ " }\n"
+ " host example2{\n"
+ " option2:param2;\n"
+ " }\n"
+ "}\n\n"
+ "subnet 20.8.110.1 netmask 255.255.255.255 {\n"
+ " host example{\n"
+ " optian:param; \n"
+ " }\n"
+ "}\n\n"
+ "subnet 20.8.110.1 netmask 255.255.255.255 {\n\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}