# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((|\s|\n)*subnet(|\s|\n)*((\d{1,3}.){3}(\d{1,3}))(|\s|\n)*netmask(|\s|\n)*((\d{1,3}.){3}(\d{1,3}))(|\s|\n)*\{(|\s|\n)+((|\s|\n)+host(|\s|\n)*(\w+)(|\s|\n)*\{(|\s|\n)*(\w*)\:(\w*)\;(|\s|\n)*\}(|\s|\n)*)*\})"
test_str = ("#DHCP Server Configuration file.\n\n"
"deny unknown-clients;\n\n"
"subnet 10.8.140.2 netmask 255.255.255.255 {\n"
" host example{\n"
" optian:param; \n"
" }\n"
" host example2{\n"
" option2:param2;\n"
" }\n"
"}\n\n"
"subnet 20.8.110.1 netmask 255.255.255.255 {\n"
" host example{\n"
" optian:param; \n"
" }\n"
"}\n\n"
"subnet 20.8.110.1 netmask 255.255.255.255 {\n\n"
"}")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.