# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?im)^(?:[^a-z].*\r?\n)*([a-z]+).*(\r?\n[^a-z].*)*/$1/g;t' <<< "(IUPAC: Disilver sulfide)
Acanthite (Y: 1855) 02.BA.35 [18] [19] [20]
(IUPAC: Disilver sulfide)
Acetamide (1974-039) 10.AA.20 [21] [22] [23]
(IUPAC: Acetic acid amide)
Achalaite (2013-103) 04.?? [24] [no] [no]
Achavalite (Y: 1939"