const regex = /(?im)^(?:[^a-z].*\r?\n)*([a-z]+).*(\r?\n[^a-z].*)*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?im)^(?:[^a-z].*\\r?\\n)*([a-z]+).*(\\r?\\n[^a-z].*)*', 'g')
const str = `(IUPAC: Disilver sulfide)
Acanthite (Y: 1855) 02.BA.35 [18] [19] [20]
(IUPAC: Disilver sulfide)
Acetamide (1974-039) 10.AA.20 [21] [22] [23]
(IUPAC: Acetic acid amide)
Achalaite (2013-103) 04.?? [24] [no] [no]
Achavalite (Y: 1939`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);