import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:0*1*0*)|(?:1|00|000)*|(?:0+1+0+)*)$";
final String string = "101\n\n"
+ "1001\n"
+ "10\n"
+ "01\n"
+ "10001011\n"
+ "101\n"
+ "1111";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}