$re = '/^((?:0*1*0*)|(?:1|00|000)*|(?:0+1+0+)*)$/';
$str = '101
1001
10
01
10001011
101
1111';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);