const regex = /^((?:0*1*0*)|(?:1|00|000)*|(?:0+1+0+)*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:0*1*0*)|(?:1|00|000)*|(?:0+1+0+)*)$', '')
const str = `101
1001
10
01
10001011
101
1111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}