const regex = /(?<=temp_min:)[^ ]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=temp_min:)[^ ]+', 'gm')
const str = `speed:10 temp_min:-14 temp_max:10
speed:5 temp_min:-12 temp_max:10 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}