$re = '/(?<=temp_min:)[^ ]+/m';
$str = 'speed:10 temp_min:-14 temp_max:10
speed:5 temp_min:-12 temp_max:10 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);